7 Comments

  1. L. Ford

    Hey Scott:

    I am very anxious to try out your Peoplesoft tools. Something like this is long overdue and I can see it being a huge benefit to those in our team.

    Unfortunately, I am a Powershell novice and was in the process of “exploring” Powershell when I found your page. Out of the box, I am having issues when trying to do the Import-Module Peoplesoft and I am unsure how to proceed/troubleshoot. Any guidance from you or any of your Powershell guru followers would be greatly appreciated. The error is:

    PS C:\temp> Import-Module Peoplesoft
    Import-Module : The ‘C:\Windows\system32\WindowsPowerShell\v1.0\Modules\Peoplesoft\Peoplesoft.psd1’ module cannot be im
    ported because its manifest contains one or more members that are not valid. The valid manifest members are (‘ModuleToP
    rocess’, ‘NestedModules’, ‘GUID’, ‘Author’, ‘CompanyName’, ‘Copyright’, ‘ModuleVersion’, ‘Description’, ‘PowerShellVers
    ion’, ‘PowerShellHostName’, ‘PowerShellHostVersion’, ‘CLRVersion’, ‘DotNetFrameworkVersion’, ‘ProcessorArchitecture’, ‘
    RequiredModules’, ‘TypesToProcess’, ‘FormatsToProcess’, ‘ScriptsToProcess’, ‘PrivateData’, ‘RequiredAssemblies’, ‘Modul
    eList’, ‘FileList’, ‘FunctionsToExport’, ‘VariablesToExport’, ‘AliasesToExport’, ‘CmdletsToExport’). Remove the members
    that are not valid (‘RootModule’), then try to import the module again.
    At line:1 char:14
    + Import-Module <<<< Peoplesoft
    + CategoryInfo : InvalidData: (C:\Windows\syst…Peoplesoft.psd1:String) [Import-Module], InvalidOperatio
    nException
    + FullyQualifiedErrorId : Modules_InvalidManifestMember,Microsoft.PowerShell.Commands.ImportModuleCommand

    • Scott Kearney

      It looks you might be running an older version or PowerShell, likely on Windows 7 or Server 2008/R2. There is a property in the module manifest, RootModule, that is not compatible. I will update the module shortly with a fix that should address this issue. In the meantime, if you’re feeling brave, you could open PeopleSoft.psd1 and remove the line beginning with RootModule. That should get you back in business.
      Let me know how it goes.

  2. Luckie Ford

    You are absolutley correct….Windows 7.

    I removed the line you suggested and gpt the following:

    PS C:\Windows\system32> import-module peoplesoft
    Import-Module : The module manifest ‘C:\Windows\system32\WindowsPowerShell\v1.0\Modules\peoplesoft\peoplesoft.psd1’ cou
    ld not be processed because it is not a valid PowerShell restricted language file. Please remove the elements that are
    not permitted by the restricted language: The string starting:
    At C:\Windows\system32\WindowsPowerShell\v1.0\Modules\peoplesoft\peoplesoft.psd1:183 char:54
    + # D e f a u l t C o m m a n d P r e f i x = ‘ <<<< '
    is missing the terminator: '.
    At C:\Windows\system32\WindowsPowerShell\v1.0\Modules\peoplesoft\peoplesoft.psd1:191 char:2
    + <<<<
    At line:1 char:14
    + import-module <<<< peoplesoft
    + CategoryInfo : ResourceUnavailable: (C:\Windows\syst…peoplesoft.psd1:String) [Import-Module], Missing
    MemberException
    + FullyQualifiedErrorId : Modules_InvalidManifest,Microsoft.PowerShell.Commands.ImportModuleCommand

    I continued down that path of removing the elements not permitted for several iterations before I decided to stop. Not certain what the impact my continued removal would have on the functionality of the tool.

    Thanks for your help on this. Apologies for not being proficient in Powershell to troubleshoot thi myself.

    • Scott Kearney

      After some thought, I have updated the compatibility for this module to PowerShell v.3.0. I have not tested the module on PowerShell v.2.0, and until I have time to test, I cannot verify that everything will work as expected. In the meantime, you do have the option to upgrade your PowerShell environment to version 3.0 (or 4.0, or the 5.0 preview – see http://technet.microsoft.com/en-us/library/hh857339.aspx). It is easy to do and worthwhile. See this article for instructions: http://technet.microsoft.com/en-us/library/hh847837.aspx.

      I am sorry that my only solution is to upgrade, but for now that is the best I can do. I will work on testing the module in version 2.0 and see if it is feasible to backport the code.

      Thanks for your feedback – I truly appreciate it!

  3. Luckie Ford

    Scott, thanks for all your help and for sharing so openly. I upgraded to version 3 and all is good.

    The next adventure for me is to adapt and learn from what you have built to now try to manage a mixed Windows/Linux environment using similar tools. We have 130 servers in our various development/QA/stage/production environments so it is very much needed.

    Thanks again!

  4. Andy D

    Very nice collection of utilities! I guess i’ve been reinventing the wheel for a while too trying to come up with a set of my own. One thing i didn’t see in your utilities is a possibility to run domain administration tasks on a remote machine or using a certain user credentials. I am curious if you ever encountered a solution of how to administer an app server or process scheduler domain on a remote server either via Invoke-Command or have -ComputerName and -Credential type arguments on each of the utilities.
    Thanks,
    Andy

  5. WLee

    Very nice! Thank you for saving me from reinventing the wheel.

    One edit I had to do was in Start-PsftDomain.ps1 within switch ($ServerType) where you had $PS_HOME, I changed to $PS_CFG_HOME for the path to the *.ubb files.

Leave a Reply